Uploaded image for project: 'Jira Align'
  1. Jira Align
  2. JIRAALIGN-5378

Creating Stories in JA from Jira Connector Results in Automation Field Set to 0, While UI-Created Stories Have NULL Value

    XMLWordPrintable

Details

    • 1
    • Severity 2 - Major
    • No

    Description

      Issue Summary

      When utilizing the Jira Connector, there is a noteworthy divergence in the way stories are generated compared to those created through the user interface (UI). Specifically, stories produced by the Jira Connector exhibit a peculiar behavior whereby the automation field is consistently set to 0, whereas stories initiated via the UI consistently maintain a NULL value in the same field.

      Steps to Reproduce

      1. Create a story in Jira and wait for it to be synchronized with Jira
      2. Using an API GET, check for the automation field. You'll see that the value is 0
      3. Creating a story directly through the UI the same field will have the value NULL

      Expected Results

      To have the same behavior independently of how the story was created.

      Actual Results

      The automation field is being created with different values, and this may affect API scripts.

      Workaround

      Currently, there is no known workaround for this behavior. A workaround will be added here when available

      Attachments

        Issue Links

          Activity

            People

              fea1a6ef3355 Yannick Genin
              82697f38779c Vasti Marucci
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Backbone Issue Sync