Uploaded image for project: 'HipChat'
  1. HipChat
  2. HCPUB-29257

"InsecurePlatformWarning" displayed when executing "hipchat upgrade -c" in the Hipchat CLI

This issue belongs to an archived project. You can view it, but you can't modify it. Learn more

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Installation/Update
    • Labels:
      None
    • Symptom Severity:
      Severity 3 - Minor

      Description

      Summary

      When executing the command hipchat upgrade -c in the Hipchat terminal an InsecurePlatformWarning error is displayed

      Environment

      • Hipchat Server 2.4.3

      Steps to Reproduce

      On an Hipchat Server 2.4.3 instance execute the command

      hipchat upgrade -c
      

      Expected Results

      The current channel for upgrades is: production
      Current Version is: Atlassian HipChat 2.4.3 (2018.10.08.214558)
      The system is up to date
      

      Actual Results

      The current channel for upgrades is: production
      Current Version is: Atlassian HipChat 2.4.3 (2018.10.08.214558)
      /opt/atlassian/hipchat/virtualenv/local/lib/python2.7/site-packages/urllib3/util/ssl_.py:369: SNIMissingWarning: An HTTPS request has been made, but the SNI (Server Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
        SNIMissingWarning
      /opt/atlassian/hipchat/virtualenv/local/lib/python2.7/site-packages/urllib3/util/ssl_.py:160: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
        InsecurePlatformWarning
      The system is up to date
      

      Note

      This error does not impede Hipchat functions or Hipchat upgrade functionality.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              dsjauwmook davy
              Archiver:
              mandreacchio Michael Andreacchio

                Dates

                Created:
                Updated:
                Resolved:
                Archived: