Uploaded image for project: 'FishEye'
  1. FishEye
  2. FE-1153

ERROR - Problem processing revisions from repo

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Handled by Support
    • Affects Version/s: 1.6.6
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Standalone
      SunOS asp1inbld001 5.10 Generic_127111-06 sun4v sparc SUNW,Sun-Fire-T200
      Solaris 10 11/06 s10s_u3wos_10 SPARC
      SUN JDK 1.5.0_15

      Description

      I'm sorry for the premature submit last time: http://jira.atlassian.com/browse/FE-1150.
      I was assuming that I've had at least 1GiB asigned. I did not (SMF ignored my FISHEYE_OPTS).

      Now, assigning more Memory (2GiB), does indeed solve half of the problem: I do not get into the Heap Space error. (With one GiB I had the heap space error AND the one below):

      For one, the application chokes on a revision, because a file changed from being a file to being a directory (or vice versa), see below.

      For the other: It still EATS CPU:
      Total: 54 processes, 301 lwps, load averages: 13.34, 14.41, 13.86

      [ Feb 12 09:27:31 Method "start" exited with status 0 ]
      ^C
      130 root@asp1inbld001 ~ # /usr/ucb/ps awwux|grep -i fisheye
      fisheye 22316 1.2 0.419457661464 ? O 09:27:31 0:09 /opt/appsrv/java/bin/sparcv9/java -Xmx2048m -Dfisheye.library.path= -Dfisheye.inst=/var/bldserv/fisheye -Djava.awt.headless=true -Djava.endorsed.dirs=/opt/bldserv/fisheye-1.6.6/lib/endorsed -jar /opt/bldserv/fisheye-1.6.6/fisheyeboot.jar start
      root 22320 0.0 0.0 1352 1240 pts/8 S 09:27:41 0:00 grep -i fisheye
      root@asp1inbld001 ~ # tail -f /var/svc/log/network-fisheye:fisheye.log
      at com.cenqua.fisheye.config.RepositoryManager.runRepository(RepositoryManager.java:222)
      at com.cenqua.fisheye.config.RootConfig.startRepositories(RootConfig.java:349)
      at com.cenqua.fisheye.ctl.Run.mainImpl(Run.java:260)
      at com.cenqua.fisheye.ctl.Run.main(Run.java:44)
      ... 6 more
      [ Feb 12 09:27:30 Leaving maintenance because clear requested. ]
      [ Feb 12 09:27:30 Enabled. ]
      [ Feb 12 09:27:30 Executing start method ("/opt/baw/svc/method/svc-fisheye start") ]
      [ Feb 12 09:27:31 Method "start" exited with status 0 ]
      INFO - FishEye 1.6.6 (build-373), Built on 2009-02-10
      INFO - FishEye: Commercial License registered to omfzd.com. ()
      INFO - Periodic polling for software updates is disabled.
      INFO - Server started on 127.0.0.1:28060 (ajp13) (control port on 127.0.0.1:28059)
      INFO - starting initial scan of repository architecture
      INFO - upgrading quicksearch data of repository artefacts
      INFO - starting initial scan of repository artefacts
      INFO - finished initial scan of repository architecture in 3s
      INFO - starting initial scan of repository omfzd
      ERROR - Problem processing revisions from repo file:///var/bldserv/svn/repos/artefacts/ due to class com.cenqua.fisheye.rep.DbException - Problem getting diff information for rev145
      com.cenqua.fisheye.rep.DbException: Problem getting diff information for rev145
      at com.cenqua.fisheye.svn.SvnRepositoryScanner.slurpRevisionBlock(SvnRepositoryScanner.java:399)
      at com.cenqua.fisheye.rep.RepositoryScanner.processRevisions(RepositoryScanner.java:451)
      at com.cenqua.fisheye.rep.RepositoryScanner.slurpRepository(RepositoryScanner.java:354)
      at com.cenqua.fisheye.rep.RepositoryScanner.slurp(RepositoryScanner.java:277)
      at com.cenqua.fisheye.rep.RepositoryScanner.ping(RepositoryScanner.java:210)
      at com.cenqua.fisheye.svn.SvnRepositoryEngine.doSlurp(SvnRepositoryEngine.java:80)
      at com.cenqua.fisheye.rep.ping.OneOffPingRequest.doRequest(OneOffPingRequest.java:30)
      at com.cenqua.fisheye.rep.ping.PingRequest.process(PingRequest.java:68)
      at com.cenqua.fisheye.rep.RepositoryHandle.processPingRequests(RepositoryHandle.java:120)
      at com.cenqua.fisheye.rep.RepositoryHandle.queuePingRequest(RepositoryHandle.java:110)
      at com.cenqua.fisheye.rep.ping.PingRequest.run(PingRequest.java:35)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: com.cenqua.fisheye.svn.diff.SvnDiffException: Exception processing diff for revision 145
      at com.cenqua.fisheye.svn.diff.DiffProcessor.processMessage(DiffProcessor.java:293)
      at com.cenqua.fisheye.svn.diff.DiffFetcher.process(DiffFetcher.java:64)
      at com.cenqua.fisheye.svn.diff.DiffFetcher.run(DiffFetcher.java:45)
      ... 1 more
      Caused by: com.cenqua.fisheye.rep.RepositoryClientException: org.tigris.subversion.javahl.ClientException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll'
      svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db'
      at com.cenqua.fisheye.svn.SvnThrottledClient.info2(SvnThrottledClient.java:118)
      at com.cenqua.fisheye.svn.diff.MessageInfo.getInfo(MessageInfo.java:119)
      at com.cenqua.fisheye.svn.diff.MessageInfo.getInfo(MessageInfo.java:110)
      at com.cenqua.fisheye.svn.diff.DiffProcessor.examinePaths(DiffProcessor.java:448)
      at com.cenqua.fisheye.svn.diff.DiffProcessor.processMessage(DiffProcessor.java:274)
      ... 3 more
      Caused by: org.tigris.subversion.javahl.ClientException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll'
      svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db'
      at org.tigris.subversion.javahl.JavaHLObjectFactory.throwException(JavaHLObjectFactory.java:723)
      at org.tmatesoft.svn.core.javahl.SVNClientImpl.throwException(SVNClientImpl.java:1852)
      at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2174)
      at org.tigris.subversion.javahl.SVNClient.info2(SVNClient.java:347)
      at com.cenqua.fisheye.svn.SvnThrottledClient.info2(SvnThrottledClient.java:111)
      ... 7 more
      Caused by: org.tmatesoft.svn.core.SVNException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll'
      svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db'
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.io.fs.FSRoot.openPath(FSRoot.java:128)
      at org.tmatesoft.svn.core.internal.io.fs.FSRoot.getRevisionNode(FSRoot.java:53)
      at org.tmatesoft.svn.core.internal.io.fs.FSRoot.checkNodeKind(FSRoot.java:139)
      at org.tmatesoft.svn.core.internal.io.fs.FSRevisionRoot.getNodeHistory(FSRevisionRoot.java:63)
      at org.tmatesoft.svn.core.internal.io.fs.FSNodeHistory.checkAncestryOfPegPath(FSNodeHistory.java:66)
      at org.tmatesoft.svn.core.internal.io.fs.FSLocationsFinder.traceNodeLocations(FSLocationsFinder.java:57)
      at org.tmatesoft.svn.core.internal.io.fs.FSRepository.getLocationsImpl(FSRepository.java:383)
      at org.tmatesoft.svn.core.io.SVNRepository.getLocations(SVNRepository.java:1087)
      at org.tmatesoft.svn.core.io.SVNRepository.getLocations(SVNRepository.java:1515)
      at org.tmatesoft.svn.core.wc.SVNBasicClient.getLocations(SVNBasicClient.java:875)
      at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2433)
      at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2205)
      at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2164)
      ... 9 more
      ERROR - Repository scanner paused.
      [ Show » ]
      Igor Galić added a comment - 12/Feb/09 03:56 AM I'm sorry for the premature submit. I was assuming that I've had at least 1GiB asigned. I did not (SMF ignored my FISHEYE_OPTS). Now, assigning more Memory (2GiB), does indeed solve half of this problem - with one GiB I had the heap space error AND the one below: For one, the application chokes on a revision, because a file changed from being a file to being a directory (or vice versa), see below. For the other: It still EATS CPU: Total: 54 processes, 301 lwps, load averages: 13.34, 14.41, 13.86[ Feb 12 09:27:31 Method "start" exited with status 0 ] ^C 130 root@asp1inbld001 ~ # /usr/ucb/ps awwux|grep -i fisheye fisheye 22316 1.2 0.419457661464 ? O 09:27:31 0:09 /opt/appsrv/java/bin/sparcv9/java -Xmx2048m -Dfisheye.library.path= -Dfisheye.inst=/var/bldserv/fisheye -Djava.awt.headless=true -Djava.endorsed.dirs=/opt/bldserv/fisheye-1.6.6/lib/endorsed -jar /opt/bldserv/fisheye-1.6.6/fisheyeboot.jar start root 22320 0.0 0.0 1352 1240 pts/8 S 09:27:41 0:00 grep -i fisheye root@asp1inbld001 ~ # tail -f /var/svc/log/network-fisheye:fisheye.log at com.cenqua.fisheye.config.RepositoryManager.runRepository(RepositoryManager.java:222) at com.cenqua.fisheye.config.RootConfig.startRepositories(RootConfig.java:349) at com.cenqua.fisheye.ctl.Run.mainImpl(Run.java:260) at com.cenqua.fisheye.ctl.Run.main(Run.java:44) ... 6 more [ Feb 12 09:27:30 Leaving maintenance because clear requested. ] [ Feb 12 09:27:30 Enabled. ] [ Feb 12 09:27:30 Executing start method ("/opt/baw/svc/method/svc-fisheye start") ] [ Feb 12 09:27:31 Method "start" exited with status 0 ] INFO - FishEye 1.6.6 (build-373), Built on 2009-02-10 INFO - FishEye: Commercial License registered to omfzd.com. () INFO - Periodic polling for software updates is disabled. INFO - Server started on 127.0.0.1:28060 (ajp13) (control port on 127.0.0.1:28059) INFO - starting initial scan of repository architecture INFO - upgrading quicksearch data of repository artefacts INFO - starting initial scan of repository artefacts INFO - finished initial scan of repository architecture in 3s INFO - starting initial scan of repository omfzd ERROR - Problem processing revisions from repo file:///var/bldserv/svn/repos/artefacts/ due to class com.cenqua.fisheye.rep.DbException - Problem getting diff information for rev145 com.cenqua.fisheye.rep.DbException: Problem getting diff information for rev145 at com.cenqua.fisheye.svn.SvnRepositoryScanner.slurpRevisionBlock(SvnRepositoryScanner.java:399) at com.cenqua.fisheye.rep.RepositoryScanner.processRevisions(RepositoryScanner.java:451) at com.cenqua.fisheye.rep.RepositoryScanner.slurpRepository(RepositoryScanner.java:354) at com.cenqua.fisheye.rep.RepositoryScanner.slurp(RepositoryScanner.java:277) at com.cenqua.fisheye.rep.RepositoryScanner.ping(RepositoryScanner.java:210) at com.cenqua.fisheye.svn.SvnRepositoryEngine.doSlurp(SvnRepositoryEngine.java:80) at com.cenqua.fisheye.rep.ping.OneOffPingRequest.doRequest(OneOffPingRequest.java:30) at com.cenqua.fisheye.rep.ping.PingRequest.process(PingRequest.java:68) at com.cenqua.fisheye.rep.RepositoryHandle.processPingRequests(RepositoryHandle.java:120) at com.cenqua.fisheye.rep.RepositoryHandle.queuePingRequest(RepositoryHandle.java:110) at com.cenqua.fisheye.rep.ping.PingRequest.run(PingRequest.java:35) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675) at java.lang.Thread.run(Thread.java:595) Caused by: com.cenqua.fisheye.svn.diff.SvnDiffException: Exception processing diff for revision 145 at com.cenqua.fisheye.svn.diff.DiffProcessor.processMessage(DiffProcessor.java:293) at com.cenqua.fisheye.svn.diff.DiffFetcher.process(DiffFetcher.java:64) at com.cenqua.fisheye.svn.diff.DiffFetcher.run(DiffFetcher.java:45) ... 1 more Caused by: com.cenqua.fisheye.rep.RepositoryClientException: org.tigris.subversion.javahl.ClientException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll' svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db' at com.cenqua.fisheye.svn.SvnThrottledClient.info2(SvnThrottledClient.java:118) at com.cenqua.fisheye.svn.diff.MessageInfo.getInfo(MessageInfo.java:119) at com.cenqua.fisheye.svn.diff.MessageInfo.getInfo(MessageInfo.java:110) at com.cenqua.fisheye.svn.diff.DiffProcessor.examinePaths(DiffProcessor.java:448) at com.cenqua.fisheye.svn.diff.DiffProcessor.processMessage(DiffProcessor.java:274) ... 3 more Caused by: org.tigris.subversion.javahl.ClientException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll' svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db' at org.tigris.subversion.javahl.JavaHLObjectFactory.throwException(JavaHLObjectFactory.java:723) at org.tmatesoft.svn.core.javahl.SVNClientImpl.throwException(SVNClientImpl.java:1852) at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2174) at org.tigris.subversion.javahl.SVNClient.info2(SVNClient.java:347) at com.cenqua.fisheye.svn.SvnThrottledClient.info2(SvnThrottledClient.java:111) ... 7 more Caused by: org.tmatesoft.svn.core.SVNException: svn: Failure opening '/gac/omfzd.Account/latest/omfzd.Account.dll' svn: '/gac/omfzd.Account/latest' is not a directory in filesystem '/var/bldserv/svn/repos/artefacts/db' at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64) at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51) at org.tmatesoft.svn.core.internal.io.fs.FSRoot.openPath(FSRoot.java:128) at org.tmatesoft.svn.core.internal.io.fs.FSRoot.getRevisionNode(FSRoot.java:53) at org.tmatesoft.svn.core.internal.io.fs.FSRoot.checkNodeKind(FSRoot.java:139) at org.tmatesoft.svn.core.internal.io.fs.FSRevisionRoot.getNodeHistory(FSRevisionRoot.java:63) at org.tmatesoft.svn.core.internal.io.fs.FSNodeHistory.checkAncestryOfPegPath(FSNodeHistory.java:66) at org.tmatesoft.svn.core.internal.io.fs.FSLocationsFinder.traceNodeLocations(FSLocationsFinder.java:57) at org.tmatesoft.svn.core.internal.io.fs.FSRepository.getLocationsImpl(FSRepository.java:383) at org.tmatesoft.svn.core.io.SVNRepository.getLocations(SVNRepository.java:1087) at org.tmatesoft.svn.core.io.SVNRepository.getLocations(SVNRepository.java:1515) at org.tmatesoft.svn.core.wc.SVNBasicClient.getLocations(SVNBasicClient.java:875) at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2433) at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2205) at org.tmatesoft.svn.core.javahl.SVNClientImpl.info2(SVNClientImpl.java:2164) ... 9 more ERROR - Repository scanner paused.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Last commented:
                9 years, 15 weeks ago