Status: Closed (View Workflow)
Affects Version/s: 2.8.3, 2.9.1, 2.9.5, 2.10.1, 2.10.2, 2.11.0
Symptom Severity:Severity 1 - Critical
Last commented by user?:true
Bug Fix Policy:
Crowd used a version of Struts 2 that was vulnerable to CVE-2017-5638. Attackers can use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Crowd.
- All versions of Crowd from 2.8.3 before 2.9.7 (the fixed version for 2.9.x), from version 2.10.1 before 2.10.3 (the fixed version for 2.10.x) and from version 2.11.0 before 2.11.1 (the fixed version for 2.11.x) are affected by this vulnerability.
- Crowd 2.11.1 is available for download from https://www.atlassian.com/software/crowd/download.
- Crowd 2.10.3 is available for download from https://www.atlassian.com/software/crowd/download-archive.
- Crowd 2.9.7 is available for download from https://www.atlassian.com/software/crowd/download-archive.
The preferred fix is to upgrade Crowd to a version that's not vulnerable (see the Fix section). If you cannot schedule an upgrade immediately, and are using Crowd 2.10 or 2.11, you can replace the affected library as a temporary workaround.
To replace the library:
- Stop Crowd
- Download struts2-core-2.3.32.jar
- Remove all existing copies of struts2-core-2.3.29.jar:
- Copy the downloaded struts2-core-2.3.32.jar into each of the lib/ directories you removed the jar from
- Restart Crowd
This temporary solution is provided only for your convenience and an upgrade to an official Crowd release should be scheduled as soon as possible.
For additional details see the full advisory.