Uploaded image for project: 'Crucible'
  1. Crucible
  2. CRUC-7055

OGNL Double Evaluation Vulnerability

    XMLWordPrintable

Details

    Description

      We have discovered and fixed a vulnerability in our fork of WebWork. Attackers can use this vulnerability to execute Java code of their choice on systems that use this framework. The attacker needs to be able to access the Crucible web interface.

      All versions of Crucible up to and including 3.6.1 are affected by this vulnerability.The vulnerability has been fixed in recent releases 3.5.5 and 3.6.2.

      For additional details see the full advisory.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              dblack David Black
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: