Uploaded image for project: 'Confluence Data Center'
  1. Confluence Data Center
  2. CONFSERVER-93164

DoS (Denial of Service) org.apache.tomcat:tomcat-catalina in Confluence Data Center and Server

    XMLWordPrintable

Details

    • Public Security Vulnerability
    • Resolution: Fixed
    • High
    • 8.6.1, 7.19.16, 8.5.3
    • 7.19.0, 7.19.1, 7.19.2, 7.19.3, 7.19.4, 7.19.5, 8.3.0, 8.4.0, 8.5.0, 7.19.6, 7.19.7, 7.19.8, 7.19.9, 7.19.10, 7.19.11, 8.3.1, 8.3.2, 8.6.0, 7.19.12, 8.4.1, 8.4.2, 8.5.1, 7.19.14, 8.5.2, 7.19.15, 8.3.3, 8.4.3, 8.3.4
    • None
    • 7.5
    • High
    • CVE-2023-42794
    • Atlassian (Internal)
    • CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
    • DoS (Denial of Service)
    • Confluence Data Center, Confluence Server

    Description

      This High severity Third-Party Dependency vulnerability was introduced in versions 7.19.1, 8.3.0, 8.4.0, 8.5.0, and 8.6.0 of Confluence Data Center and Server.

      This DoS Dependency vulnerability only impacts Windows instances, with a CVSS Score of 7.5 and a CVSS Vector of CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has no impact to confidentiality, no impact to integrity, high impact to availability, and requires no user interaction.

      Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:

      • Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.16
      • Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.3
      • Confluence Data Center and Server 8.6: Upgrade to a release greater than or equal to 8.6.1

      See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives).

      The National Vulnerability Database provides the following description for this vulnerability: Incomplete Cleanup vulnerability in Apache Tomcat.

      The internal fork of Commons FileUpload packaged with Apache Tomcat 9.0.70 through 9.0.80 and 8.5.85 through 8.5.93 included an unreleased,
      in progress refactoring that exposed a potential denial of service on
      Windows if a web application opened a stream for an uploaded file but
      failed to close the stream. The file would never be deleted from disk
      creating the possibility of an eventual denial of service due to the
      disk being full.

      Users are recommended to upgrade to version 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              security-metrics-bot Security Metrics Bot
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: