Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-67940

Confluence Server Webwork OGNL injection - CVE-2021-26084

    XMLWordPrintable

Details

    • Severity 1 - Critical
    • 9.8
    • Critical
    • CVE-2021-26084

    Description

      This vulnerability is being actively exploited in the wild. Affected servers should be patched immediately.

      An OGNL injection vulnerability exists that allows an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance.

      The CVE ID is CVE-2021-26084.

      Acknowledgements

      The issue was discovered by Benny Jacob (SnowyOwl) via the Atlassian public bug bounty program.

      The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

      Affected versions:

      • version < 6.13.23
      • 6.14.0 ≤ version < 7.4.11
      • 7.5.0 ≤ version < 7.11.5
      • 7.12.0 ≤ version < 7.12.5

      Fixed versions:

      • 6.13.23
      • 7.4.11
      • 7.11.6
      • 7.12.5
      • 7.13.0  

       

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              security-metrics-bot Security Metrics Bot
              Votes:
              0 Vote for this issue
              Watchers:
              160 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: