Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-60118

Stored XSS in the Livesearch macro - CVE-2020-36290

    XMLWordPrintable

Details

    Description

      The Livesearch macro in Confluence Server and Data Center before version 7.4.5, from version 7.5.0 before 7.6.3, and from version 7.7.0 before version 7.7.4 allows remote attackers with permission to edit a page or blog to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the page excerpt functionality.

       

      Affected versions:

      • version < 7.4.5
      • 7.5.0 ≤ version < 7.6.3
      • 7.7.0 ≤ version < 7.7.0

      Fixed versions:

      • 7.4.5
      • 7.6.3
      • 7.7.4

      Attachments

        Issue Links

          Activity

            People

              oshen@atlassian.com Oliver Shen
              ablack@atlassian.com Anton 🆎 (AU)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: