Uploaded image for project: 'Confluence Server'
  1. Confluence Server
  2. CONFSERVER-57802

Bundle AdoptOpenJDK with Confluence

    XMLWordPrintable

    Details

    • Feedback Policy:
      We collect Confluence feedback from various sources, and we evaluate what we've collected when planning our product roadmap. To understand how this piece of feedback will be reviewed, see An updated workflow for server feature suggestions.

      Description

      Confluence 6.13 and later supports both Oracle JDK and AdoptOpenJDK. Previously we bundled the Oracle JRE. 

      This change will bundle AdoptOpenJDK 8u192-b12, which will be used when installing Confluence using the Windows and Linux installer. 

      Admins can still choose to switch to Oracle JDK if they prefer. See Change the Java vendor or version Confluence uses

      Note: Confluence 6.13.0, 6.13.1, and 6.14.0 all bundled Oracle JRE.
      6.13.2+ and 6.14.1+ will have AdoptOpenJDK. 
       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rrobins Rachel Robins
                Participants:
                Last Touched By:
                Katherine Yabut
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Last commented:
                  14 weeks, 6 days ago