Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-54107

Page does not render correctly once any html code inserted on HTML Macro

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Low
    • Resolution: Answered
    • 6.0.1, 6.3.4, 6.6.1
    • None
    • Macros - Other Macros
    • None

    Description

      The page does not render correctly once any HTML code inserted on HTML macro. The other content missing after save though it available during preview mode

      STEPS TO REPRODUCE
      1. Create a new page and apply the Storage Format.txt
      2. Preview the page
      3. Then save
      EXPECTED BEHAVIOR

      All content should be shown exactly like in preview mode after the save

      ACTUAL BEHAVIOR

      Only HTML macro content is shown on the page after the save

      After save:

      Preview:

      Note

      Tried to remove any macro on the page to see if the behavior change, but no luck. Even the simplest HTML code return the same result. But keeping the HTML macro empty return the expected behavior

       

       
       

      Attachments

        1. Preview mode.png
          Preview mode.png
          46 kB
        2. Result after save.png
          Result after save.png
          33 kB
        3. Storage Format.txt
          3 kB

        Issue Links

          Activity

            People

              Unassigned Unassigned
              mzakaria@atlassian.com Zulfarhan Zakaria (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: