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Bug
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Resolution: Fixed
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High
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5.5, 5.6, 5.7, 5.7.1
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None
Symptoms:
Some users fail to receive some page, or blog post notifications. It seems to happen sporadically, but consistently for a specific space.
Potential cause:
The notifications plugin queues up emails with a retry mechanism. This retry attempts to re-send to a recipient when failure happens for whatever reason. This includes failure to verify the email address validity (e.g., a user has a blank, or empty email address).
The retry does not remove the currently failing recipient, and re-queues the notification, causing it to fail next time (for the same reason). After a set number of failures, the entire batch of recipients is discarded, and thus some recipients (who does have valid email address) fail to receive any email.
Workaround:
Find the offending user (user with no/invalid email address) by going to the Manage watcher dialog on the page, and remove them, or add a valid email address.
- is duplicated by
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CONFSERVER-36734 Cloud releases blog on confluence.atlassian.com does not send notifications to watchers
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- Closed
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- is related to
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CONFSERVER-32537 Sharing Page with Group Stops if A User Exists with no Email Address
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- Closed
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To damian.egli1 and anyone else who might be interested:
I ran into this same problem last week. I managed to list the spaces, pages and blogposts who are being Watched by a user who does not have a valid email address – and the user who is watching them – with this SQL query:
Tested in Confluence 5.6.6 and PostgreSQL. You might need some small changes you're using some other DB.