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  1. Confluence Data Center
  2. CONFSERVER-36801

Some Email Notifications fail to send, if one of the users in the list of users receiving them has an invalid email address

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    Description

      Symptoms:

      Some users fail to receive some page, or blog post notifications. It seems to happen sporadically, but consistently for a specific space.

      Potential cause:

      The notifications plugin queues up emails with a retry mechanism. This retry attempts to re-send to a recipient when failure happens for whatever reason. This includes failure to verify the email address validity (e.g., a user has a blank, or empty email address).

      The retry does not remove the currently failing recipient, and re-queues the notification, causing it to fail next time (for the same reason). After a set number of failures, the entire batch of recipients is discarded, and thus some recipients (who does have valid email address) fail to receive any email.

      Workaround:
      Find the offending user (user with no/invalid email address) by going to the Manage watcher dialog on the page, and remove them, or add a valid email address.

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              jxie Chii
              jxie Chii
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