Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-11767

Configured Left Navigation theme leads to "doUpgrade failed" when upgrading Confluence 2.2.x to Confluence 2.8

    XMLWordPrintable

Details

    Description

      Upgrade task failed when trying to upgrade from Confluence version 2.2.9 to Confluence version 2.8:

      2008-05-08 16:57:17,109 INFO [main] [atlassian.confluence.upgrade.MoveBandanaConfigsToDatabaseUpgradeTask] doUpgrade Starting Bandana configuration migration
      2008-05-08 16:57:17,296 ERROR [main] [com.atlassian.upgrade.AbstractUpgradeManager] doUpgrade Upgrade failed: com.atlassian.confluence.extra.leftnavigation.LeftNavSettings : com.atlassian.confluence.extra.leftnavigation.LeftNavSettings
      

      Accessing Confluence via browser leads to an error page as shown in screenshot, error.jpg.

      It occurs when one of the space in Confluence instance 2.2.9 is using the Left Navigation theme and the theme has been configured via the "Configure theme" session.

      A workaround would be to perform an incremental upgrade. For example, first upgrade the Confluence instance from version 2.2.9 to 2.7.x. Confirm the upgrade process is successful and later perform an upgrade again from version 2.7.x to version 2.8.0.

      Attachments

        1. error.JPG
          76 kB
          Tony Cheah Tong Nyee [Atlassian]

        Activity

          People

            Unassigned Unassigned
            tcheah Tony Cheah Tong Nyee [Atlassian]
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: