Uploaded image for project: 'Confluence Cloud'
  1. Confluence Cloud
  2. CONFCLOUD-70566

blog post macro is not showing excerpts

    XMLWordPrintable

Details

    Description

      Issue Description :
      The blog post macro is not displaying the excerpts of blogs in "excerpts" display mode

      Steps to reproduce the issue

      • Create a blog post with or without excerpt macro.
      • Come to a different page or overview page of the space and enter blog post macro.
      • In macro config mode on "Content Type to Display" select excerpts.
      • Publish the page.

      Expected behavior:

      it should display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.

      Actual Behavior :
      It's not showing any extracted text from the blog on overview page. It is acting as if Title is selected in "Content type to display"

      Entire works fine :

       
      The title also works fine:

      Workaround :

      Select either of them Entire or Title which is far from ideal workaround.

      Attachments

        1. screenshot-1 (1).png
          136 kB
          TruptiD
        2. screenshot-2.png
          175 kB
          TruptiD
        3. screenshot-3.png
          126 kB
          TruptiD

        Issue Links

          Activity

            People

              472cc2e7ccc5 Andrey Markelov
              b0b849db5d18 TruptiD
              Votes:
              55 Vote for this issue
              Watchers:
              46 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: