Uploaded image for project: 'Confluence Server'
  1. Confluence Server
  2. CONFSERVER-36080

OGNL Double Evaluation Vulnerability

    XMLWordPrintable

    Details

      Description

      We have discovered and fixed a vulnerability in our fork of WebWork. Attackers can use this vulnerability to execute Java code of their choice on systems that use this framework. The attacker needs to have an account and be able to access the Confluence web interface.

      All versions of Confluence up to and including 5.6 are affected by this vulnerability.

      The vulnerability has been fixed in releases 5.5.7 and 5.6.6.

      For additional details see the full advisory.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              dblack David Black
              Votes:
              0 Vote for this issue
              Watchers:
              31 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: