Uploaded image for project: 'Confluence Server'
  1. Confluence Server
  2. CONFSERVER-31518

Page properties report missing content due to nbsp

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.1.3, 5.1.5
    • Fix Version/s: 5.5-OD-24, 5.5.1
    • Component/s: None
    • Environment:

      Description

      Synopsis

      When using the content report Macro, and showing specific columns may fail to show the contents of the named column, even if the name of the column is correct.

      Environment

      • Issue occurs in Chrome, IE, Firefox on Windows 7 and 8 - doesn't appear to be browser specific
      • Macro version is the latest version

      Steps to Reproduce:

      1. Create the following page in Confluence; and give it a label of "Policies"
        <ac:structured-macro ac:name="details">
          <ac:rich-text-body>
            <table>
              <tbody>
                <tr>
                  <th><strong>Policy number</strong></th>
                  <td>something</td>
                </tr>
                <tr>
                  <th><strong>Policy application</strong></th>
                  <td>Organisation</td>
                </tr>
                <tr>
                  <th><strong>Policy category</strong></th>
                  <td>Finance</td>
                </tr>
                <tr>
                  <th><strong>Authorisation</strong></th>
                  <td>Chief Financial Officer</td>
                </tr>
              </tbody>
            </table>
          </ac:rich-text-body>
        </ac:structured-macro>
        
      2. On a seperate page within the same space, add the following content:
        <h1>Policies</h1>
        <p><ac:structured-macro ac:name="detailssummary"><ac:parameter ac:name="label">policy</ac:parameter></ac:structured-macro></p>
        
      3. Verify the report is shown correctly.
      4. Double click on the macro to edit the report
      5. In the "Columns to show" field, enter "Authorisation"
      6. Verify that while the column header shows, the content field does not.

      Expected Behaviour

      The content should be shown for this column, but it is blank instead.

        Attachments

        1. error_log_.txt
          60 kB
        2. screenshot-1.jpg
          screenshot-1.jpg
          174 kB
        3. screenshot-2.jpg
          screenshot-2.jpg
          105 kB
        4. screenshot-3.jpg
          screenshot-3.jpg
          12 kB
        5. source with marked nbsp.pdf
          132 kB

          Issue Links

            Activity

              People

              • Votes:
                7 Vote for this issue
                Watchers:
                19 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Last commented:
                  5 years, 11 weeks ago