Uploaded image for project: 'Confluence Server'
  1. Confluence Server
  2. CONFSERVER-23184

Setup hangs loading users from JIRA

    XMLWordPrintable

    Details

      Description

      During post-installation of Confluence 4.0 beta 2, there is an option to load users from an existing JIRA installation. Attempting to do this causes setup to hang. I cannot proceed and cannot escape this screen, even after restarting the service. I see the little spinning circle I am told that less than a second elapsed endlessly. It does say:

      "Local administrator account created.

      We have created a local administrator with the same username and password as the JIRA system administrator you provided. This will ensure that you can always log into Confluence to update the system configuration."

      The next button is visible but cannot be clicked.

      If I refresh the page I get one of the following next to the spinning circle (in no particular order): "Synchronisation completed successfully.", "Synchronisation started.", and "embedded.crowd.directory.caching.sync.full"

      I noticed something else odd - in JIRA, on the Configure Other Applications screen. I had created an application named "confluence" with IP address ::1, 127.0.0.1 and the actual IP address of my machine. This had worked find with Confluence 3.5. However after setting up Confluence 4.0 beta 2 there is a new application here with the following application name:

      "Confluence - localhost - c2f77bbd-57fe-3852-bda6-8bfc6c0cdca9"

      The only IP address on that is the real IP address, it doesn't have the local addresses. I tried adding these and restarting confluence (from init.d) but it didn't help.

      I have confirmed this is not a problem with Confluence 3.5 (though this is post-setup in that version). I have tried recreating the confluence database and deleting the application data - this allows me to run through setup again but it hangs at the same place.

      Workaround:

      1. In Chrome right click the greyed out button and select 'Inspect'
      2. The HTML should read:
        <input class="aui-button aui-button-primary" id="nextButton" type="submit" value="Next >>" disabled="disabled">
        
      3. Remove the disabled attribute so it will looks like:
        <input class="aui-button aui-button-primary" id="nextButton" type="submit" value="Next >>">
        
      4. The Next button will be enabled for the next page.

        Attachments

          Issue Links

            Activity

              Dates

              • Created:
                Updated:
                Resolved:
                Last commented:
                1 year, 8 weeks, 6 days ago