Uploaded image for project: 'Bitbucket Server'
  1. Bitbucket Server
  2. BSERV-9570

Blame generates an error with Git 2.11.1+

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 4.13.0, 4.14.0
    • Fix Version/s: 4.13.1, 4.14.1
    • Component/s: None
    • Labels:
      None

      Description

      Summary

      Blame generates an error 'Line <filename> "Line <filename> with Git 2.11.1

      Steps to Reproduce

      1. Go to a repo source
      2. Choose a file with non-trivial history (more than one change)
      3. Click the Blame button

      Expected Results

      You should view the Blame

      Actual Results

      You see an error on the screen:

      Workaround

      Downgrade to Git version 2.11.0

      Looks like this issue is caused by the fact Git 2.11.1 produces more lines in blame output than Git 2.11.0. See https://github.com/git/git/commit/4e768329847c8226a230406041fe249adea245cf

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: