-
Type:
Public Security Vulnerability
-
Resolution: Fixed
-
Priority:
High
-
Affects Version/s: 9.1.0, 9.2.0, 9.3.0, 9.4.0, 9.5.0, 9.4.1, 9.4.2, 9.6.0, 9.4.3, 9.4.4, 9.4.5, 10.0.0, 9.4.6, 9.4.7, 9.4.8, 9.4.9, 9.4.11, 9.4.12, 9.4.13, 9.4.14, 9.4.15, 9.4.16, 10.1.1, 10.2.0, 9.4.17, 9.4.18, 10.2.1, 10.3.0, 9.4.19, 10.2.2, 10.2.3, 9.4.20, 10.2.4, 9.4.21
-
Component/s: None
-
8.7
-
High
-
CVE-2026-12802
-
Atlassian (Internal)
-
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/U:Amber
-
Cryptographic Failure
-
Bitbucket Data Center
This High severity Cryptographic Failure vulnerability was introduced in versions 9.1.0, 9.2.0, 9.3.0, 9.4.0, 9.4.1, 9.4.2, 9.4.3, 9.4.4, 9.4.5, 9.4.6, 9.4.7, 9.4.8, 9.4.9, 9.4.11, 9.4.12, 9.4.13, 9.4.14, 9.4.15, 9.4.16, 9.4.17, 9.4.18, 9.4.19, 9.4.20, 9.4.21, 9.5.0, 9.6.0, 10.0.0, 10.1.1, 10.2.0, 10.2.1, 10.2.2, 10.2.3, 10.2.4, and 10.3.0 of Bitbucket Data Center.
This Cryptographic Failure vulnerability, with a CVSS Score of 8.7 and a CVSS Vector of CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/U:Amber allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, no impact to integrity, no impact to availability, and requires no user interaction.
Atlassian recommends that Bitbucket Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:
Bitbucket Data Center 9.4: Upgrade to a release greater than or equal to 9.4.24
Bitbucket Data Center 10.2: Upgrade to a release greater than or equal to 10.2.7
See the release notes (https://confluence.atlassian.com/bitbucketserver/bitbucket-data-center-and-server-release-notes). You can download the latest version of Bitbucket Data Center from the download center (https://www.atlassian.com/software/bitbucket/download-archives).
The National Vulnerability Database provides the following description for this vulnerability: In Bouncy Castle for Java before 1.85, CMS AuthEnvelopedData fails to enforce tag-length on decryption. This issue also affects Bouncy Castle for Java LTS before 2.73.12, and Bouncy Castle for Java FIPS (BC-FJA) before bcpkix-fips 1.0.12 (1.0.X series), 2.0.12 (2.0.X series) and 2.1.12 (2.1.X series).