Uploaded image for project: 'Bamboo'
  1. Bamboo
  2. BAM-5379

include ${bamboo.dependency.xxx} variable usage in documentation

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5.1, 3.4.3, 4.0
    • Fix Version/s: None
    • Component/s: Documentation (User)
    • Labels:
    • Last commented by user?:
      true
    • Comments:
      4
    • Sprint:
      Sprint 2

      Description

      bamboo has some metadata for dependent builds that can be used as build specific variables.

      https://support.atlassian.com/browse/BSP-2697

        Attachments

          Issue Links

            Activity

            markus lang Markus Lang added a comment -

            I'm currently trying to find out how a child build can query the build key of the parent build which has triggered the child build. While searching the net I've found this Jira Issue which looks promising to answer my question.

            Since I don't have access to the linked Support Jira Issue I'd like to ask if someone could comment the available $

            {bamboo.dependency.*}

            variables to this Jira issue. Or can I find the available variables elsewhere? So far my search wasn't successful.. Thanks!

            anton@atlassian.com Anton Mazkovoi [Atlassian] added a comment - - edited

            Here is the reply on the linked support ticket:

            you can use variable: ${bamboo.dependency.parent.0} in the child plan.
            It will substituted by the PLAN-KEY-<Number> like

            Substituting variable: ${bamboo.dependency.parent.0} with PARENT-PAR-26.

            The ${bamboo.dependency.parent.0} variable can be viewed in the (child) plan's metadata tab.

            akhachatryan Armen Khachatryan [Atlassian] added a comment -

            I was able to reproduce this problem in Bamboo version 3.4.3. I used a script task with "Inline" option. $

            {bamboo.dependency.parent.0}

            variable doesn't get substituted.

            rbattaglin Renan Battaglin added a comment -

            Created BAM-11411 so that the feature can be fixed.


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Last commented:
                  4 years, 11 weeks, 6 days ago