Uploaded image for project: 'Bamboo'
  1. Bamboo
  2. BAM-4292

Maven builds importing bamboo web get atlassian-core 3.6

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 2.3 M9
    • Fix Version/s: 2.3
    • Component/s: Plugins
    • Labels:
      None

      Description

      I've attached the dependency tree for an Atlassian plugin that imports bamboo-web 2.3-rc1-r2. Bamboo web is pulling in atlassian-core 3.6, indirectly through atlassian johnson. atlassian-core 3.6 does not include the com.atlassian.core.i18n package, so if the plugin defines action that extends BambooActionSupport, the compilation will fail saying that com.atlassian.core.i18n cannot be found. The work around for this is to explicitly define a dependency on atlassian-core 4.5 in dependency managament section of the plugins pom, the fix is for Bamboo web to explicitly defining this dependency, if that's what it depends on.

        Attachments

          Activity

            People

            Assignee:
            jdumay JamesA
            Reporter:
            jroper James Roper [Atlassian]
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: