Uploaded image for project: 'Bamboo'
  1. Bamboo
  2. BAM-3674

Failing Since Wrong Build #

    XMLWordPrintable

    Details

      Description

      Since upgrading to 2.2, the "Failing Since Build" indications on an individual build result's main page appear to be wrong. Prior to 2.1, it would list the build the actual test failed in. Since 2.2, it just the first failed build (since the last succesfull build). For example, see: http://build.limewire.org/bamboo/browse/LW-COMPONENTS-1986 . That says that in the XmppFriendSubscriptionTest suite, the Friend request denied test was failing since LW-COMPONENTS-1984. But, if you look at http://build.limewire.org/bamboo/browse/LW-COMPONENTS-1984, that test didn't fail – a different one did. If you look at http://build.limewire.org/bamboo/browse/LW-COMPONENTS-1985 (the build in between the two), that is where the test failed.

      Because Bamboo doesn't tell you where the actual test failed anymore (it definitely used to do this), it's very hard to prioritize which tests to fix. We used to glance at it and say, "Oh, that's been failing for a month – let's take a look at it. These others only failed last night, it might have been a fluke."

      This is a very major regression in functionality IMO.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mwent Marek Went (Inactive)
              Reporter:
              sberlin Sam Berlin
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: