-
Type:
Public Security Vulnerability
-
Resolution: Fixed
-
Priority:
High
-
Affects Version/s: 12.1.0, 12.1.1, 12.1.2, 12.1.3, 12.1.6, 12.1.7, 12.1.8, 12.1.9, 12.1.10, 12.1.4, 12.1.5, 12.1.11
-
Component/s: None
-
7.5
-
High
-
CVE-2026-54399
-
Atlassian (Internal)
-
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
-
DoS (Denial of Service)
-
Bamboo Data Center
This High severity DoS (Denial of Service) vulnerability was introduced in version 12.1.0 of Bamboo Data Center.
This DoS (Denial of Service) vulnerability, with a CVSS Score of 7.5 and a CVSS Vector of CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation, which has no impact to confidentiality, no impact to integrity, high impact to availability, and requires no user interaction.
Atlassian recommends that Bamboo Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:
- Bamboo Data Center 12.1: Upgrade to a release greater than or equal to 12.1.12
See the release notes (https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html). You can
download the latest version of Bamboo Data Center from the download center
(https://www.atlassian.com/software/bamboo/download-archives).
The National Vulnerability Database provides the following description for this vulnerability:
Uncontrolled Resource Consumption vulnerability in the HTTP/1.1 message parser in Apache HttpComponents Core (5.4.2 and earlier, 5.5-beta1 and earlier) allows an remote attacker to cause a denial of service through memory exhaustion by sending messages with excessive number of headers / excessive header length