Status: Closed (View Workflow)
Affects Version/s: 5.13.1, 5.13.2, 184.108.40.206, 220.127.116.11, 5.15.1, 5.15.2
Symptom Severity:Severity 1 - Critical
Bug Fix Policy:
Bamboo used a version of Struts 2 that was vulnerable to CVE-2017-5638. Attackers can use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo
- All versions of Bamboo from 5.1.0 before 5.14.5 (the fixed version for 5.14.x) and from 5.15.0 but less than 5.15.3 (the fixed version for 5.15.x) are affected by this vulnerability.
- Bamboo 5.15.3 is available for download from https://www.atlassian.com/software/bamboo/download.
- Bamboo 5.14.5 is available for download from https://www.atlassian.com/software/bamboo/download-archives.
The preferred fix is to upgrade your Bamboo using one of the links from the Fix section. If you cannot schedule an upgrade immediately, you can replace the affected library as a temporary workaround.
- Bamboo 5.9.x, 5.10.x, 5.11.x, 5.12.x - use struts2-core-18.104.22.168-atlassian-7.jar
- Bamboo 5.13.x - use struts2-core-2.5.1-atlassian-11.jar (this jar has struts2 version 2.5.1 with the same fix applied in version 22.214.171.124)
To replace the library, remove the existing struts2-core library from $BAMBOO_DIR/WEB-INF/lib, replace it with one matching your Bamboo version and restart your Bamboo server. This temporary solution is provided only for your convenience and an upgrade to an official Bamboo release should be scheduled as soon as possible.
For additional details see the full advisory.