Bamboo had a resource that deserialised arbitrary user input without restriction. Attackers can use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo. To exploit this issue, attackers need to be able to access the Bamboo web interface.
- All versions of Bamboo from 2.2 before 5.8.5 (the fixed version for 5.8.x) and from 5.9.0 before 5.9.7 (the fixed version for 5.9.x) are affected by this vulnerability.
- Bamboo 5.9.7 is available for download from https://www.atlassian.com/software/bamboo/download.
- Bamboo 5.8.5 is available for download from https://www.atlassian.com/software/bamboo/download-archives.
We would like to credit Matthias Kaiser of Code White for reporting this issue to us.
For additional details see the full advisory.