Uploaded image for project: 'Bamboo'
  1. Bamboo
  2. BAM-1469

Disabled agents are reenabled on restart

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 2.3
    • Component/s: Agents
    • Labels:
      None

      Description

      From http://forums.atlassian.com/thread.jspa?messageID=257250330#257250330,

      Disabling a build queue is not persistent between restarts. This is annoying as we have a number of build queues that all tried to run at once as soon as bamboo is restarted. I wanted to turn them on one at a time to make sure they worked. I ended up disabling each build individually which did work.

      To replicate this scenario;
      1) Create build queue
      2) Disable build queue
      3) Up on restart, the build queue's are enabled.

      Thank you Mark(mg) for reporting this issue.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kbrazulewicz Krystian Brazulewicz
              Reporter:
              asridhar AjayA
              Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 11h
                  11h