Details
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Bug
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Resolution: Unresolved
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Medium
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None
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3.2.0, 3.2.1, 3.2.3, 3.2.4
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88
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Severity 2 - Major
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0
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Description
NOTE: This bug report is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding bug report.
Summary
When attempting to migrate from JIRA Server 7.2.X running JIRA Service Desk 3.2.X, the import process fails displaying an error that indicates JIRA Service Desk should first be upgraded before being imported into Cloud.
Environment
JIRA Cloud - v1000.319.1
JIRA Service Desk - v3.3.0-OD-1000.335.0
Steps to Reproduce
- Ensure your JIRA Server install is running JIRA 7.2.0 or later
- Ensure you have installed JIRA Service Desk 3.2.0 or later from the Atlassian Marketplace
- Run a full export of your JIRA Server install
- Attempt to import this into JIRA Cloud
Expected Results
The External System Import process should complete without error
Actual Results
The External System Import process fails and displays the following error:
"We can't complete your upgrade. It looks like the data you are trying to import is from an earlier version of JIRA Service Desk. You need to upgrade to JIRA Service Desk 3.0 first, then export new data and try again. Read these upgrade notes for instructions: http://confluence.atlassian.com/migration/jira-7/server_jira+jsd_upgrade"
Notes
Searching in the entities.xml file, you will see that the version of Service Desk running has not been completely upgraded:
com.atlassian.activeobjects.admin.ActiveObjectsPluginToTablesMapping : {"AO_54307E_VIEWPORTFIELDVALUE":{"key":"com.atlassian.servicedesk","name":"JIRA Service Desk","version":"2.3.6","vendorName":"Atlassian","vendorUrl":"http://www.atlassian.com"},"AO_54307E_QUEUECOLUMN":{"key":"com.atlassian.servicedesk","name":"JIRA Service Desk","version":"2.3.6","vendorName":"Atlassian","vendorUrl":"http://www.atlassian.com"}
This is caused by the customer most likely installed at some point the JIRA Service Desk plugin jar (even though it was not licensed) OR Skipping major versions
Workaround
The JIRA Server install must be downgraded in order to resolve this issue
- Setup a temporary install of JIRA Server 7.1.9 and connect to a new database
- Create an XML backup of JIRA 7.2 Server
- import this backup into the 7.1.9 Server.
- When running the import, JIRA will confirm that you want to downgrade your data
- Once your JIRA 7.1.9 Server is running with your 7.2 data you can proceed to install JIRA Service Desk 3.0.0 https://marketplace.atlassian.com/plugins/com.atlassian.servicedesk.application/versions]
- Make sure a license is added. You can generate an evaluation license by going to my.atlassian.com.
- To apply this license, you will want to go here: JIRA Administration > Applications > Versions & Licenses
- Once the installation is complete and you have added the license, refresh the Versions & Licenses page
- Confirm that you see the Service Desk options on the left side. This will confirm that Service Desk loaded.
- Create an XML backup of your JIRA 7.1.9 Server
- Import this backup into your JIRA 7.2 instance
- Create a backup of your JIRA 7.2 Server instance
- Import this backup into your JIRA Cloud instance
Attachments
Issue Links
- causes
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JSDCLOUD-4577 Error Message on Failed JIRA Import Leads Misunderstanding
- Closed
- is duplicated by
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JSDSERVER-4766 Cannot import Jira backup into Cloud because of wrong version in backup file
- Closed
- relates to
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JSDCLOUD-8475 Importing JIRA Service Desk Server site export into JIRA Cloud fails with version error
- Closed
- mentioned in
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