[CONFSERVER-39322] Page Properties Report sorting on column with Status Macro's is incorrect Created: 20/Sep/2015  Updated: 20/Apr/2018

Status: Open
Project: Confluence Server
Component/s: Editor - Page / Comment Editor
Affects Version/s: 5.7.1, 6.2.0, 6.4.1
Fix Version/s: None

Type: Bug Priority: Low
Reporter: Maarten Cautreels (Digital Nomads) Assignee: Unassigned
Resolution: Unresolved Votes: 42
Labels: affects-server, editor, editor-macros, page-properties-report-macro
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: Zip Archive Confluence-space-export-111307-124.xml.zip     PNG File screenshot-actual.png     PNG File screenshot-expected.png    
Issue Links:
Part
is incorporated by CONFSERVER-42801 Umbrella Issue for Page Property and ... Resolved
Symptom Severity: Minor
UIS: 4
Support reference count: 5
Participants:
Last Touched By: SET Analytics Bot
Last commented: 1 year, 47 weeks, 2 days ago

 Description   

Steps to Reproduce

  1. Create a page with a Page Properties Report
  2. Enable sorting for the Page Properties Report on a column which contains Status Macro's
    • Fe.: R | G | O | Y
  3. Enable "Reverse Sort"
    (See screenshot-actual.png)

Actual Result
The pages are sorted (propably on color instead of content) like this:

  1. Y
  2. O
  3. O
  4. O
  5. R
  6. R
  7. G
  8. G

Expected Result
I expect the pages to be sorted on the status in the following order:

  1. Y
  2. R
  3. R
  4. O
  5. O
  6. O
  7. G
  8. G

Note(s)
When I manually sort the table (by clicking the column header twice) I get the expected result. (See screenshot-expected.png)
I've included a space export so it's easier to reproduce.



 Comments   
Comment by Benjamin Ingersoll [ 26/May/2016 ]

I can confirm this issue affects version 5.9.7 as well.
A workaround used to be wrapping the Page Properties Report with a Table Plus macro (Bob Swift plugin) and doing the sorting within that macro, however, with the latest upgrade and the "generating page properties report..." message when a page loads, the Table Plus workaround no longer works. (Works when previewing the page, but when actually viewing it, it does not.)

Generated at Sat Apr 21 20:51:39 UTC 2018 using JIRA 7.9.0-m0002#79000-sha1:c2c604d204a01a7a5c2a35ed342adc394ebbb6b0.