Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-48869

Team Calendars disabled at startup on Confluence 5.7.x

    XMLWordPrintable

    Details

      Description

      NOTE: This bug report is for Confluence Server. Using Confluence Cloud? See the corresponding bug report.

      Summary

      After installing or upgrading to Team Calendars 5.2.16 Team Calendars is disabled at startup

      Steps to Reproduce

      1. Install Confluence 5.7.x
      2. Install Team Calendars 5.2.16
      3. Restart Confluence

      Expected Results

      Team Calendars would be enabled with the other plugins at startup

      Actual Results

      The below exception is thrown in the atlassian-confluence.log file:

      2015-08-04 17:20:38,171 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai
      nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active
      objects.external)(version>=0.22.2))
      2015-08-04 17:20:38,171 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPluginInstalledHelper] getRequiredPlugins Cannot determine required plugins, 
      cannot resolve bundle 'com.atlassian.confluence.extra.team-calendars'
      2015-08-04 17:20:41,147 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai
      nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active
      objects.external)(version>=0.22.2))
      2015-08-04 17:20:41,781 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugi
      n 'com.atlassian.confluence.extra.team-calendars' : Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20
      .0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)).  This error usually occurs when your plugin impo
      rts a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or
       there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN
      2015-08-04 17:20:41,782 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 'com.atlassian.confluence.extra.t
      eam-calendars'
      2015-08-04 17:20:41,783 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Because of this exception
      com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars
              at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479)
              at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310)
              at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136)
              at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104)
      ...
      Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2))
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
              at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
              at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
              at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:456)
              ... 18 more
      2015-08-04 17:20:41,784 ERROR [localhost-startStop-1] [atlassian.plugin.manager.PluginEnabler] actualEnable Unable to enable plugin com.atlassian.confluence.extra.team-calendars
      com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars
              at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479)
              at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310)
              at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136)
              at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104)
              at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1199)
      ...
      Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2))
      

      Workaround 1

      Uninstall Team Calendars 5.2.16 and install Team Calendars 5.2.13

      Workaround 2

      Upgrade Confluence to higher than 5.8

      Workaround 3

      In some cases the plugin can be enabled in the UI after the initial attempt to enable times out.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gvotruong Giang Vo
              Reporter:
              aworley Ann Worley (Inactive)
              Votes:
              7 Vote for this issue
              Watchers:
              21 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: