JIRA
  1. JIRA
  2. JRA-5789

Transition order should be sortable for each Step Name

    Details

    • Type: New Feature New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.2
    • Fix Version/s: 4.1
    • Component/s: Workflow
    • Labels:
      None

      Description

      Transitions for each workflow step are shown in the order they have been created in the workflow editor.

      We have a very large workflow with many transitions per step. It would be nice if the transitions could be sorted so that the could be presented in a more "sequential" order.

      Of course i could create the workflow in the rigth order, byt the workflow is created as a copy of the JIRA workflow and therefore our transitions are shown after the Resolve and Close transitions wich looks a little bit strange.

      Even if i created the workflow from scratch, it would not be possible to edit the order later.

        Issue Links

          Activity

          Stefan Niedermann added a comment -

          whats going on here? the workaround with opsbar-sequence is good, thx.
          but its definitly what it is - just a workaround.
          arrows on each step to move would be great, drag'n'drop would be wunderfull.

          William Crighton [CCC] added a comment -

          My group has finally updated our Transition Reorder X Plugin which provides a drag & drop interface for reordering transitions.

          For more details visit our plugin listing here:

          Stefan Niedermann added a comment -

          Why is this issue marked as solved? Fine, there is a plug-in, but in my opinion this basic action should be standard for jira! imagine, you needed a plug-in for sorting versions and components too?!

          Philippe Busque added a comment -

          I concur. Is this issue supposed to be fixed in Jira 6 or does it rely on a non-free third parties plug-in to fix this?
          If it has been marked as solved because of the plugin, then it isn't for us. If the plug-in was a free plugin from Atlassian, that would be ok.
          But paying an extra 500-999$ over the maintenance fee only to order transition, a feature that should be built-in, is a bit excessive.

          William Crighton [CCC] added a comment -

          The issue was marked as solved when Atlassian implemented the ops-bar sequence property for the transition to control transition sorting when the issue is rendered. The issue being marked as solved had nothing to do with our plugin - looking at the issue history this issue was resolved on 9 Apr 2010 at 1.55am (CST). We didn't take our plugin commercial, compatible with JIRA 5+ until the end of Q1 2013.
          We wrote the plugin because modifying the ops-bar sequence takes forever - a total PITA if the workflow is very large. It takes 4 clicks, plus waiting through the screen refreshes, to modify a single sequence. And you can only verify the results by transiting an issue through the workflow. So we priced the plugin according to how much time it saves and what it will cost us to keep it maintained and current.
          We tried the 'free' plugin route initially back in 2009 but were unable to keep the plugin current with JIRA, or even mildly current with JIRA - it's hard to justify working for free when there are paying customers waiting impatiently on the end of every phone call.

          Anyway, I just wanted to clearly state Atlassian closed this issue when they implemented a method for ordering workflow transitions with a transition property value, not because of our plugin.


            People

            • Assignee:
              Unassigned
              Reporter:
              Lars
            • Votes:
              35 Vote for this issue
              Watchers:
              27 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: