JIRA
  1. JIRA
  2. JRA-28092

JIRA 4.4.4 UPM 1.4.1 asks users to upgrade to incompatible JIRA 5.x plugins

    Details

      Description

      In JIRA version 4.4.4 bundling UPM 1.4.1 - the UPM will ask users to upgrade to incompatible JIRA 5.x plugins.

      For example please see screenshot where the UPM is asking the user to install GreenHopper 5.9.x that will not work with JIRA 4.4.4

      Workaround

      As a workaround for this please perform the following note it will require a JIRA restart:

      • Go to this page and download the UPM .jar file for UPM 2.2
      • Put that .jar into the folder [JIRA_HOME]/plugins/installed-plugins if there already is a UPM .jar in that folder remove it first.
      • Restart JIRA, the new UPM should be in place.

        Activity

        Hide
        Arun Bhalla [Atlassian] added a comment -

        My apologies, this was a bug in the Plugin Exchange. We have updated the service, so the Universal Plugin Manager should be returning only the compatible plugin versions now.

        Show
        Arun Bhalla [Atlassian] added a comment - My apologies, this was a bug in the Plugin Exchange . We have updated the service, so the Universal Plugin Manager should be returning only the compatible plugin versions now.

          People

          • Assignee:
            Arun Bhalla [Atlassian]
            Reporter:
            Michael Andreacchio [Atlassian]
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: