Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0, 5.0, 5.0 - EAP
    • Fix Version/s: 5.1
    • Component/s: JIRA Development Kit
    • Labels:
      None

      Description

      Tempo has a recursive velocity macro problem producing lots of error messages in the logs.

      ERROR admin 1063x1459x1 usx21i 0:0:0:0:0:0:0:1 /secure/Tempo.jspa [velocity] VM #printSection: error : too few arguments to macro. Wanted 1 got 0
      

      This seems to be a bug in Velocity but already solved in Velocity 1.5 since March 2007.
      JIRA still comes with Velocity 1.4. Is there a good reason why Velocity has not been updated yet in JIRA?

      Decription of the bug and samples to reproduce can be found here:
      https://issues.apache.org/jira/browse/VELOCITY-108
      https://issues.apache.org/jira/browse/VELOCITY-71

      Regards

        Attachments

          Issue Links

            Activity

            pjesi Viðar Svansson [Tempo] added a comment -

              People

              • Assignee:
                Unassigned
                Reporter:
                kristin@tmsoftware.is Kristín Hreinsdóttir
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: