Details
-
Bug
-
Resolution: Fixed
-
Low
-
4.3.4
-
None
-
4.03
-
Description
Symptoms
When starting JIRA it displays a HTTP 404, as below:
HTTP Status 404 - type Status report message description The requested resource () is not available. Apache Tomcat/6.0.32
The following is displayed in the atlassian-jira.log:
JIRA 4.3.4 build: 620 started. You can now access JIRA through your web browser. ******************************************************************************************************************************************************************************************************** 2011-06-27 11:45:24,728 main FATAL [atlassian.jira.upgrade.UpgradeLauncher] A RuntimeException occurred during UpgradeLauncher servlet context initialisation - Failed to verify the license.. com.atlassian.extras.common.LicenseException: Failed to verify the license. at com.atlassian.extras.decoder.v2.Version2LicenseDecoder.checkAndGetLicenseText(Version2LicenseDecoder.java:186) at com.atlassian.extras.decoder.v2.Version2LicenseDecoder.doDecode(Version2LicenseDecoder.java:124) at com.atlassian.extras.decoder.api.AbstractLicenseDecoder.decode(AbstractLicenseDecoder.java:14) at com.atlassian.extras.decoder.api.DelegatingLicenseDecoder.decode(DelegatingLicenseDecoder.java:44) at com.atlassian.extras.core.DefaultLicenseManager.decodeLicense(DefaultLicenseManager.java:63)
Cause
The License key stored in database is invalid and the above error is shown in the browser page when the user attempts to access JIRA.
Workaround
Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.
- Make sure you have your license keys available from your my.atlassian.com account.
- Stop JIRA.
- Identify license keys in the database with the following SQL:
SELECT * FROM propertyentry e JOIN propertytext t ON e.id = t.id WHERE property_key LIKE '%icense%' or property_key like '%LICENSE%' or property_key like '%License%';
- Remove them with the following SQL:
DELETE FROM propertyentry WHERE id = <ID from previous SQL>;
- Start JIRA.
- Manually enter all the license keys, as in Updating your JIRA License Details and also through the UPM.
- Test that JIRA and your plugins are working with the license keys.
- Restart JIRA.
Expected Behaviour
JIRA should able to handle this situation and prompt a page for user to insert valid license key rather than generate a 404 and cause the instance to be unusable.