JIRA
  1. JIRA
  2. JRA-10506

export to excel exports only up to 1000 issues

    Details

    • Type: Bug Bug
    • Status: Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.6.2
    • Fix Version/s: 3.7
    • Component/s: Import / Export
    • Labels:
      None
    • Environment:

      standalone with mysql 4.0.24_Debian-10sarge1-log db on linux 2.4.31-bf2.4 with jdk 1.5.0_05

      Description

      I do a search with a search result > 1000 issues.
      From the first page of the search I select to view as Excel by clicking on "Current fields".
      I get an excel document with only 1000 issues.
      If I start from another page I get the issues starting from that page.
      Also in that case I get only a maximum of 1000 issues.

      In my previous Jira versions (rel 3.3.3 and 3.5.1), doing an excel export I always got the whole list,
      so that is my expectation also for release 3.6.2.

        Issue Links

          Activity

          Bettina Zucker created issue -
          Bettina Zucker made changes -
          Field Original Value New Value
          Link This issue is related to JRA-8899 [ JRA-8899 ]
          Mei Yan Chan [Atlassian] added a comment -

          Hi Bettina,

          This is caused by a bug in 3.6:

          JRA-9932

          There is a patch attached to the issue. Follow through the steps and please let us know how it goes. Thanks!
          Our apologies for the inconvenience.

          Regards,
          Mei

          Bettina Zucker added a comment -

          How can it be?

          Jra-9932 has FixVersions = 3.6.1
          and I have Jira version 3.6.2!
          So that bug should not be present in my version of Jira.

          I think it is a new bug.

          In any case, I'm not going to patch back my new Jira 3.6.2
          to the older release 3.6.1 without a good explanation.

          Cheers
          Bettina Zucker

          Mei Yan Chan [Atlassian] added a comment -

          Hi Bettina,

          I had a look at the problem again and sorry about the incorrect direction that I've pointed you to. Please ignore the post above.

          You are possibly encountering two problems at the moment:
          1. Unable to export >1000 issues
          2. Export to Excel doesn't export all records only from the current page (similar to the issue that you have linked)

          In order to rectify the first problem, please refer to JRA-8214. The reason exporting more than 1000 issues is possible in your previous version is because tempMax was set to 10000. However, in 3.6.2 the value is only set to 1000. You may edit this value to by following the steps defined in the given link.

          Regarding the second problem, it may still be a bug at the moment which is currently being tracked at JRA-8899. Please cast your vote in order to get it fixed or add yourself s a watcher for future updates.

          Hope this answers your question. Let us know how it goes and please contact us if you have further questions. Thanks!

          Regards,
          Mei

          Bettina Zucker added a comment -

          Mei,

          thank you very much, it worked!

          Cheers
          Bettina

          Scott Farquhar [Atlassian] added a comment -

          Export to excel now exports all issues. However, marking this issue as duplicate as the two linked issues already cover this functionality.

          Scott Farquhar [Atlassian] made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Checked Code Coverage No
          Fix Version/s 3.7 [ 11847 ]
          Number of Developers Alone
          Testing Strategy No Testing
          Code Review No
          Resolution Duplicate [ 3 ]
          Testing Performed Never
          Scott Farquhar [Atlassian] made changes -
          Workflow jira [ 48993 ] JIRA Bug Workflow v1 [ 53353 ]
          Scott Farquhar [Atlassian] made changes -
          Workflow JIRA Bug Workflow v1 [ 53353 ] JIRA Bug Workflow v2 [ 58484 ]
          Martin Burton added a comment -

          Hi,

          We are running Jira 3.12.3-#302 and we are seeing the 1000 issue limit when exporting to Excel. I looked at JRA-8214 but my version of includes/navigator/table/header.jsp does not have the line mentioned (or the number 1000). I also tried copying the URL and changing the tempMax parameter to a higher value, but Internet Explorer gives an error.

          Martin.

          Anton Mazkovoi [Atlassian] added a comment -

          Hi Martin,

          I think the best thing to do is to create a support request in our support system:
          http://support.atlassian.com
          and describe the error you are seeing.

          Our Support Team should be able to help.

          Cheers,
          Anton

          Martin Burton added a comment -

          I found the answer in another Jira issue. For anyone else edit atlassian-jira\WEB-INF\classes\jira-application.properties and change the value for jira.search.views.default.max

          Martin.

          Alex Holtz added a comment -
          Brad Baker [Atlassian] made changes -
          Workflow JIRA Bug Workflow v2 [ 58484 ] JIRA Bug Workflow + Quality v3 [ 193323 ]
          Nabil Zakaria [Administrative Account] made changes -
          Workflow JIRA Bug Workflow + Quality v3 [ 193323 ] JIRA Bug Workflow + Quality v4 [ 255112 ]
          Peter Leschev [Admin] made changes -
          Workflow JIRA Bug Workflow + Quality v4 [ 255112 ] JIRA Bug Workflow w Kanban v5 [ 263961 ]
          Oswaldo Hernandez [Atlassian] Bugmaster made changes -
          Workflow JIRA Bug Workflow w Kanban v5 [ 263961 ] JIRA Bug Workflow w Kanban v6 [ 660718 ]
          Oswaldo Hernandez [Atlassian] Bugmaster made changes -
          Workflow JIRA Bug Workflow w Kanban v5 [ 660718 ] JIRA Bug Workflow w Kanban v6 [ 668422 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Bettina Zucker
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: