Uploaded image for project: 'Identity'
  1. Identity
  2. ID-249

"Unable to add access as there are no default groups for JIRA" message does not tell you how to fix it

      Summary

      When granting users access to JIRA Application or when creating a User with JIRA access on Cloud, the following message is shown:
      "Unable to add access as there are no default groups for JIRA. Please contact support."

      The message suggests that there are no groups linked to the "JIRA Users" Global Permission but jira-users is linked correctly to that global permission.

      Cause:
      There are no JIRA use groups that do not have Admin permission

      Environment: JIRA Cloud

      Steps to Reproduce

      1. Add jira-users to JIRA Administrators Global Permissions
      2. verify jira-users it is listed in JIRA Users
      3. Create a new user or grant a user Application Access

      Expected Results: Error explaining that there are no default groups for JIRA, with a link to resolve it.

      Actual Results: "Unable to add access as there are no default groups for JIRA. Please contact support." message is shown.

      Notes:
      There is no documentation on what 'default groups for JIRA' really is.

      Workaround
      Remove jira-users group from the JIRA Administrators global permission

            [ID-249] "Unable to add access as there are no default groups for JIRA" message does not tell you how to fix it

            Michael Andreacchio made changes -
            Workflow Original: reviewflow [ 915032 ] New: JAC Bug Workflow v3 [ 3258071 ]
            Status Original: Resolved [ 5 ] New: Closed [ 6 ]
            Kieren (Inactive) made changes -
            Resolution New: Fixed [ 1 ]
            Status Original: Verified [ 10005 ] New: Resolved [ 5 ]
            Eric S (Inactive) made changes -
            Component/s Original: User management [ 33497 ]
            Eric S (Inactive) made changes -
            Component/s New: Site Admin (users and groups) [ 48696 ]
            Mark Klinski (Inactive) made changes -
            Attachment Original: screenshot-1.png [ 190229 ]
            Mark Klinski (Inactive) made changes -
            Attachment New: screenshot-1.png [ 190229 ]
            Oswaldo Hernandez (Inactive) made changes -
            Component/s New: User Management [ 33497 ]
            Component/s Original: User Management [ 10125 ]
            Key Original: JRA-43794 New: ID-249
            Affects Version/s Original: 6.5-OD-05 [ 54015 ]
            Workflow Original: JIRA Bug Workflow w Kanban v6 [ 898579 ] New: reviewflow [ 898579 ]
            Project Original: JIRA [ 10240 ] New: Identity [ 16810 ]
            Geoff Crain (Inactive) made changes -
            Link New: This issue relates to ROTP-3550 [ ROTP-3550 ]
            Geoff Crain (Inactive) made changes -
            Description Original: h3. Summary
            When granting users access to JIRA Application or when creating a User with JIRA access on Cloud, the following message is shown:
            {color:red}"Unable to add access as there are no default groups for JIRA. Please contact support."{color}

            The message suggests that there are no groups linked to the "JIRA Users" [Global Permission|https://confluence.atlassian.com/display/JIRACLOUD/Managing+Global+Permissions] but *jira-users* is linked correctly to that global permission.

            *Cause:*
            The *jira-users* group is also linked to the "JIRA Administrators" permission.

            *Environment:* JIRA Cloud

            *Steps to Reproduce*
            # Add jira-users to *JIRA Administrators* Global Permissions
            # verify jira-users it is listed in *JIRA Users*
            # Create a new user or grant a user Application Access

            *Expected Results:* The user is created.

            *Actual Results:* "Unable to add access as there are no default groups for JIRA. Please contact support." message is shown.

            *Notes:*
            The message is incorrectly saying that there are no default groups to JIRA. If the error is because the default group *jira-users* is also a JIRA Administrator, then the message should reflect that.
            Also, there is no documentation on what 'default groups for JIRA' really is. A rewording of the error message including "Global Permissions" would help understand the source of the error.

            *Workaround*
            Remove *jira-users* group from the *JIRA Administrators* global permission
            New: h3. Summary
            When granting users access to JIRA Application or when creating a User with JIRA access on Cloud, the following message is shown:
            {color:red}"Unable to add access as there are no default groups for JIRA. Please contact support."{color}

            The message suggests that there are no groups linked to the "JIRA Users" [Global Permission|https://confluence.atlassian.com/display/JIRACLOUD/Managing+Global+Permissions] but *jira-users* is linked correctly to that global permission.

            *Cause:*
            There are no JIRA use groups that do not have Admin permission

            *Environment:* JIRA Cloud

            *Steps to Reproduce*
            # Add jira-users to *JIRA Administrators* Global Permissions
            # verify jira-users it is listed in *JIRA Users*
            # Create a new user or grant a user Application Access

            *Expected Results:* Error explaining that there are no default groups for JIRA, with a link to resolve it.

            *Actual Results:* "Unable to add access as there are no default groups for JIRA. Please contact support." message is shown.

            *Notes:*
            There is no documentation on what 'default groups for JIRA' really is.

            *Workaround*
            Remove *jira-users* group from the *JIRA Administrators* global permission
            Geoff Crain (Inactive) made changes -
            Summary Original: "Unable to add access as there are no default groups for JIRA" message is incorrect New: "Unable to add access as there are no default groups for JIRA" message does not tell you how to fix it

              Unassigned Unassigned
              mfernandezbadii Mauro Badii (Inactive)
              Affected customers:
              0 This affects my team
              Watchers:
              6 Start watching this issue

                Created:
                Updated:
                Resolved: