Uploaded image for project: 'Crowd'
  1. Crowd
  2. CWD-3430

Webwork 2 code injection vulnerability

    XMLWordPrintable

    Details

      Description

      We have discovered a vulnerability in WebWork 2, which is a part of the Struts web framework.

      In specific circumstances, attackers can use this vulnerability to execute Java code of their choice on systems that use these frameworks.

      In case of Crowd, the attacker needs to be able to access Crowd Web interface. A valid user account is not is required to exploit this vulnerability.

      Customers should be advised that this effects all previously released versions of standalone Crowd server, except Crowd
      2.3.9, 2.4.10, 2.5.5, 2.6.4, or later. Standalone Crowd is not used in OnDemand.

      For more information on this issue, please see the security advisory here.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              vosipov Vitaly Osipov [Atlassian]
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: