Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-58392

When Service Desk is integrated with Confluence 6.15.4, knowledge base articles can't be open from the Customer Portal (error 404)

    XMLWordPrintable

    Details

      Description

      Issue Description

      When Service Desk is integrated with Confluence 6.15.4, the following issue happens: when a customer clicks on a KB article from the Service Desk Customer Portal, they get the following error:

      The knowledge base article could not be found
      


      Note that when the Customer clicks on the same KB article from the issue creation form, the page loads properly:

      Steps to Reproduce

      • Install any Service Desk version such as 3.15.x, 3.16.x, 4.1.0
      • Install Confluence 6.15.4
      • Create an application link between Confluence and Service Desk using Oauth with impersonation
      • Configure an external user directory in Confluence using the JIRA directory to ensure that the JIRA users exist in Confluence
      • Create a space in Confluence
      • Create an article in this space (with "laptop" as a title)
      • Create a new Service Desk project, and configure the Knowledge Base setting as follows:
        • Use the space created in Confluence
        • Select the option "All active users and customers can access the knowledge base without a Confluence license"
      • Log into the Service Desk customer portal with a user which does not have a Confluence license
      • Search for the KB article by typing "laptop" in the search box
      • Click on the KB article

      Observed

      • The KB article loads forever (we get a spinning wheel)
      • If we refresh the page, we get the following error in the UI:
        The knowledge base article could not be found
        

      • If we collect a HAR file, we get a a 404 error with the request "/rest/servicedesk/1/customer/models"
      • The following error is thrown in the logs:
        2019-06-06 14:48:54,958 http-nio-8080-exec-7 ERROR customer1 888x235x1 oqwnl5 0:0:0:0:0:0:0:1 /servicedesk/customer/kb/view/884742 [c.a.s.i.api.applink.BaseAppLinkResponseHandler] Applink request has returned an error %s
        2019-06-06 14:48:54,958 http-nio-8080-exec-7 ERROR customer1 888x235x1 oqwnl5 0:0:0:0:0:0:0:1 /servicedesk/customer/kb/view/884742 [c.a.s.i.api.applink.BaseAppLinkResponseHandler] Confluence could not find the requested page and returned a 404
        

      Additional notes

      • The issue occurs whether the Confluence application is configured with anonymous access or not
      • The issue does not happen in the 2 following scenarios:
        • The user has a Confluence license: in this case, this user can open the KB article from both the Customer Portal homepage, and from the request creation form
        • The user does not have a Confluence license and opens the KB article from the request creation form

        Attachments

        1. Step1.png
          Step1.png
          100 kB
        2. Step2.png
          Step2.png
          31 kB
        3. Step3.png
          Step3.png
          69 kB
        4. Step4.png
          Step4.png
          43 kB

          Issue Links

            Activity

              People

              Assignee:
              nhdang Nhan Dang
              Reporter:
              jrey Julien Rey
              Votes:
              8 Vote for this issue
              Watchers:
              27 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: