Uploaded image for project: 'Confluence'
  1. Confluence
  2. CONF-8023

The plugin 'org.apache.maven.plugins:maven-resources-plugin' does not exist or no valid version could be found

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Resolved Locally
    • Affects Version/s: 2.3.3
    • Fix Version/s: None
    • Component/s: Plugins
    • Labels:
      None
    • Environment:

      Standalone, JDK 1.5, Windows Advanced Server 2003

    • Last commented by user?:
      true

      Description

      Using Maven 2 to build a plugin. Downloaded latest PDK. In running Maven 2, this is what we get:
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] The plugin 'org.apache.maven.plugins:maven-resources-plugin' does not exi
      st or no valid version could be found
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: The plugin 'org.apache.m
      aven.plugins:maven-resources-plugin' does not exist or no valid version could be
      found
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(Defa
      ultLifecycleExecutor.java:1286)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoDescriptor
      (DefaultLifecycleExecutor.java:1522)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindLifecycleForP
      ackaging(DefaultLifecycleExecutor.java:1016)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycl
      eMappings(DefaultLifecycleExecutor.java:980)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
      ltLifecycleExecutor.java:458)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
      dleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
      ts(DefaultLifecycleExecutor.java:278)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
      fecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:330)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:123)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:272)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.version.PluginVersionNotFoundException: The p

        Attachments

          Activity

          christopher.owen@atlassian.com Christopher Owen [Atlassian] added a comment -

          Hi Bijan,

          We've found that this can happen if the plugin is somehow corrupted in the local repository.

          What you might like trying is to remove the plugin directory from your local maven 2 repo

          e.g.

          rm -rf ~/.m2/repository/org/apache/maven/plugins/maven-resources-plugin

          Cheers,
          Chris

          bmarjan@pershing.com Bijan Marjan added a comment -

          OK, please close this case for now. Thanks for the response.

          steshaw Steven Shaw added a comment -

          Same thing happened to me with maven-2.0.7. Deleting maven-resources-plugin resolves this issue for me. However, please please fix this as it was difficult to find this page

          christopher.owen@atlassian.com Christopher Owen [Atlassian] added a comment -

          Hi Steven,

          Unfortunately this is a problem with Maven and not Confluence itself. Until maven has a better way of protecting itself from corrupted plugins, there's not much we can do.

          Chris

          steshaw Steven Shaw added a comment -

          Sorry for the confusion Christopher, I figured I'd come across the Maven JIRA


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Last commented:
                8 years, 11 weeks, 1 day ago