XMLWordPrintable

    Details

    • Support reference count:
      10
    • Feedback Policy:
      We collect Confluence feedback from various sources, and we evaluate what we've collected when planning our product roadmap. To understand how this piece of feedback will be reviewed, see our Implementation of New Features Policy.

      Description

      NOTE: This suggestion is for Confluence Server. Using Confluence Cloud? See the corresponding suggestion.

      Confluence does not support Postgres 9.6, and will throw error messages like the following:

      org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist
      
      

      Upgrading the Postgres Driver to the newest version seems to resolve the problem, however Atlassian Support will not be able to provide support for this configuration until this improvement is implemented in a future version.

      Upgrade the Postgres Driver
      1. Shut down Confluence
      2. Copy confluence-install/confluence/WEB-INF/lib/postgresql-9.x-xxxx.jdbc4.jar to a safe location as a backup, and then delete the file.
      3. From the Postgres Website, download the most recent driver and copy it to the same location
        • Despite its name, the JDBC 9.4 driver is compatible with Postgres 9.6
      4. Start Confluence again

      Notes

      This is documented here

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ttranminh Tam Tran Minh
              Reporter:
              dnorton@atlassian.com Dave Norton
              Votes:
              54 Vote for this issue
              Watchers:
              58 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: