Uploaded image for project: 'Confluence'
  1. Confluence
  2. CONF-14183

Pasting into Table Cells in the RTE causes problems

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Obsolete
    • Affects Version/s: 2.10
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      Safari 3, Mac OS X 10.5.6

    • Last commented by user?:
      true

      Attachments

        Activity

        don.willis@atlassian.com Don Willis [Atlassian] added a comment -

        Describing the video:
        Pasting content of one table cell into another table cell creates extra cells at the end of the row.
        Roundtripping through wiki markup actually fixes the problem.
        May only happen on Safari.

        don.willis@atlassian.com Don Willis [Atlassian] added a comment - - edited

        I couldn't reproduce this in Confluence or TinyMCE, so it's lucky you posted a video or I'd say you're making it up. I did find the table editing in Safari pretty flakey in Confluence 2.10, Confluence 3.0_m2 and TinyMCE 3.2.1.1 though.

        jnolen Jonathan Nolen [Atlassian] added a comment -

        Well, not sure what to do to help repro it, but I can say that it happens to me nearly every time.

        don.willis@atlassian.com Don Willis [Atlassian] added a comment -

        Oh good. Requires an environment more specific than MacOSX + Safari 3. That will be fun
        Could you try testing the behaviour on the TinyMCE demo, to check if it's a Confluence thing or a tinyMCE thing?

        jnolen Jonathan Nolen [Atlassian] added a comment -

        Yep – I can reproduce it in the TinyMCE demo. Not our fault, I guess.

        pfragemann Per Fragemann [Atlassian] added a comment -

        Don, should we close this as won't fix then?

        don.willis@atlassian.com Don Willis [Atlassian] added a comment -

        We might fix it one day by upgrading to a later version of TinyMCE. It has the tinymce label so we can tell it exists in tinymce. I think it's worth tracking how many things we may fix by upgrading.

        pfragemann Per Fragemann [Atlassian] added a comment -

        Since the TinyMCE upgrade happened in 2.10, I backdate the issue. It should not show up in the 3.0 filter.

        jnolen Jonathan Nolen [Atlassian] added a comment -

        FYI, I just tried this on the TinyMCE Demo again, and I can no longer reproduce the problem. So looks like their latest versions may have fixed it.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Last commented:
              7 years, 9 weeks, 3 days ago