Uploaded image for project: 'Bamboo'
  1. Bamboo
  2. BAM-18735

Remote Code Execution - CVE-2017-9514

    XMLWordPrintable

Details

    Description

      Bamboo has a resource which accepts a YAML file and did not sufficiently restrict which classes could be loaded. An attacker who can login to Bamboo as a user is able to use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo.

       

      Affected versions:

      • Versions of Bamboo starting with 6.0.0 before 6.0.5 (the fixed version for 6.0.x ) and from before 6.1.4 (the fixed version for 6.1.x) are affected by this vulnerability.

       

      Fix:

       

      For additional details see the full advisory.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              aminozhenko alexmin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: