Details
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Bug
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Resolution: Fixed
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Highest
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5.9.3, 5.15.5, 6.1.6, 6.3.2, 6.6.1, 6.6.2, 6.8.1, 6.9.1, 6.8.3
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25
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Severity 3 - Minor
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14
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Description
http://blog.swisstech.net/2012/12/environments-in-tanuki-softwares-java.html?m=1
tanukisoftwaresupport December 26, 2012 at 3:22 AM
Hi,What version of the Java Service Wrapper are you using?
This bug should have already been fixed since version 3.3.0.Best Regards,
Tanuki Software Support TeamReply
tanukisoftwaresupport December 26, 2012 at 3:33 AM
Sorry, I forgot to mention it in my first post. To fix the issue yourself with the 3.2.* version of the script, please open the checkUser() function and change the following line:
su -m $RUN_AS_USER -c "\"$REALPATH\" $2"
to:
su - $RUN_AS_USER -c "\"$REALPATH\" $2"
This appears to have been fixed in the service wrapper for some time, and while the workaround is pretty simple, it took hours for me to find it.
Attachments
Issue Links
- causes
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BAM-19683 Bamboo service does not start on Windows with 64-bit Java
- Closed
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PS-49533 Loading...
- is duplicated by
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BAM-9756 Upgrade wrapper Library version
- Closed
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BAM-11336 Upgrade Service Wrappers
- Closed
- relates to
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BAM-20394 Admin can't stop remote agent
- Closed
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BAM-18608 Increase the default time taken for the agents to reconnect in case the server is temporarily down
- Closed
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PSR-250 Loading...
- was cloned as
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BDEV-9819 Loading...