Details
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Bug
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Resolution: Timed out
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Medium
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3
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Severity 2 - Major
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Description
Scenario
After using the Site Importer tool to restore a Confluence backup, users are presented with the error below when trying to create new users:
Oops - an error has occurred (https://example.atlassian.net/wiki/)System Error A system error has occurred — our apologies! For immediate troubleshooting, consult our knowledge base (http://confluence.atlassian.com/display/CONFKB/Confluence+Knowledge+Base+Home) for a solution. If you would like to receive support from Atlassian's support team, ask your Confluence administrator (https://example.atlassian.net/wiki/contactadministrators.action) to create a support issue on Atlassian's support system (http://support.atlassian.com/) with the following information: a description of your problem and what you were doing at the time it occurred a copy of the error and system information found below a copy of the application logs (if possible). Your Confluence administrator can use the support request form (https://example.atlassian.net/wiki/admin/raisesupportrequest.action) to create a support ticket which will include this information. We will respond as promptly as possible. Thank you! Return to site homepage… (https://example.atlassian.net/wiki/) Cause com.atlassian.confluence.core.InsufficientPrivilegeException: User [example] does not have the required privileges. at com.atlassian.confluence.user.DefaultUserAccessor.addMembership(DefaultUserAccessor.java:169)
Cause
Apparently the import overwrites the groups in OnDemand, and the users group gets deleted in case it is not present in the backup. With the absence of that group, Confluence is unable to include new users to it and throws the error above.
Workaround
Create the users group manually after the import